CATPROC – Packages and Types Invalid in Dba_registry


Dba_registry shows 'Packages and Types' as invalid. How it can be validated.

SQL> select comp_name, version, status from dba_registry;

COMP_NAME VERSION STATUS 
---------------------------------------- ---------- ---------- 
Oracle XML Database 10.2.0.1.0 VALID 
Oracle Database Catalog Views 10.2.0.1.0 VALID 
Oracle Database Packages and Types 10.2.0.1.0 INVALID 
JServer JAVA Virtual Machine 10.2.0.1.0 VALID 
Oracle XDK 10.2.0.1.0 VALID 
Oracle Database Java Packages 10.2.0.1.0 VALID

SOLUTION

$sqlplus "/as sysdba"
SQL> spool fix_cat_logfile.txt
SQL> startup upgrade 
-- Use 'startup migrate' if database version is lower than 10g. 
SQL > @?/rdbms/admin/catalog.sql 
SQL > @?/rdbms/admin/catproc.sql 
SQL > @?/rdbms/admin/utlrp.sql
SQL> spool off

Restart the database after executing the scripts.

sqlplus / as sysdba

shutdown immediate

startup

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: